0

I just retrieve maintenance (archive FTP/SQL) of a website running Drupal 6.22…

But… I have an Debian 8 server with Apache 2.4, PHP 5.6 and MySQL 5.5... :)

==> So my question is : what is the upper version of these software (Apache, PHP, MySQL) can run Drupal 6.22 ? I think PHP 5.3, but after ? (I know that 6.22 is an old version but I will update after first run).

Really thanks for your help.

  • Oddly there hasn't been a question about D6's requirements (though D7 has one). FWIW, I have instances D6 on PHP 5.5/5.6 without it breaking, albeit with some warnings. The d.o. requirements handout the caveat as such. – Shawn Conn Sep 30 '15 at 19:54
1

Per the d.o. requirements page, D6's requirements are:

  • Web server: Apache, Nginx, or Microsoft IIS
  • Database: MySQL 4.1 or higher, PostgreSQL 7.1,
  • PHP: PHP 5.x only (5.2.5 or higher recommended). Warning: support for PHP 4.x has been dropped. Drupal core should work with PHP 5.3.x, but PHP 5.3.x and higher may produce errors or unexpected behavior especially for contributed modules and themes.
0

Latest version of Drupal 6 LTS can be run at PHP 7.3 + MySQL 8.0 environment. https://github.com/d6lts/drupal

I had more than twice performance speed up for complex website after migrating from PHP 5.3 + MySQL 5.7.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.