0

I was restructuring the modules directory (moving modules from /sites/all/modules/ to /sites/default/modules/) because we are adding a multi-site and do not want to share all the modules. After moving them I ran drush rr in the /sites/default/ directory and then drush cc all for good measure.

Everything went fine except that now on all of the content editor forms the rich text editors are all gone. I can click "switch to plain text editor" and it works fine, but CKEditor is now completely gone.

I tried doing drush pmu ckeditor and then drush en ckeditor -y and cleared cache again but for some reason the rich text editors still appear completely blank.

I checked the chrome inspector console for errors and found that the site is still looking in the /sites/all/ sub-directories for the module.

/sites/all/modules/custom/custom_cke_plugin/ckeditor/custom_cke_plugin/plugin.js?t=DAED Failed to load resource: the server responded with a status of 404 (Not Found)

ckeditor.js?nviice:219 Uncaught [CKEDITOR.resourceManager.load] Resource name "nyuslink" was not found at "/sites/all/modules/custom/custom_cke_plugin/ckeditor/custom_cke_plugin/plugin.js?t=DAED".

Has anyone had issues with moving CKEditor module and found any resolution?

3
  • in Drupal admin CK editor settings u need to update the path, its probably still trying to read from sites/all. Sorry im on mobile, cant provide proper answer.
    – No Sssweat
    Sep 30, 2015 at 23:22
  • Are you using the WYSIQIG module + CKEditor library or are you using the CKEditor module (drupal.org/project/ckeditor)?
    – gerzenstl
    Sep 30, 2015 at 23:59
  • CKEditor module.
    – CR47
    Oct 1, 2015 at 14:14

1 Answer 1

1

Go to yourwebsite.com/admin/config/content/ckeditor/editg

In there you probably need to change the path to ckeditor. As you can see from the screen shot the %m stands for /sites/all/modules/ckeditor

so you need to erase %m/ckeditor and instead put /sites/default/modules/ckeditor/ckeditor

Click image to enlarge

enter image description here

1
  • In addition to updating this I also had to update a feature which had configuration for a custom ckeditor plugin module I had built and forgotten about. The configuration still referred to sites/all/ instead of sites/default/.
    – CR47
    Oct 1, 2015 at 14:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.