I was trying to migrate my site from one computer to another. I have imported .sql file from database from my first database (unfortunately forgot to clear cache) and created a new database in the second and exported the data. Then i have tried to point the settings.php's database array to the newly created database in the second computer but when i tried to access the page, i get a white screen with the following error

Fatal error: require_once(): Failed opening required '/var/www/html/sites/pullup.local/modules/remote_stream_wrapper/remote_stream_wrapper.inc' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/html/includes/bootstrap.inc on line 3186

Where sites/pullup.local was my site folder in the first computer which is not present here. Then i tried to remove all the entries in the database starting with "cache". Even after clearing all the entries in the cache tables i am getting same error and I am not understanding that from where old folder path coming.

I also tried to remove the database entry from settings.php then it is working normal as the web installation page coming up. So I think something caches the old folder in the database (DRUPAL_ROOT variable value is cached).

How can I fix the problem?

1 Answer 1


Drupal uses code registry to load the files containing a class or an interface. While the code registry is cached in cache_bootstrap, it is contained in the registry and registry_file database tables.

To rebuild it, I would edit those database tables to change the path shown in the filename row to match the new site's path. Other methods that require bootstrapping Drupal would probably not work, since any class Drupal would use would not be found, causing a PHP exception, and stopping the bootstrap, with the effect that Drupal would not run the necessary code.

  • 1
    Worked perfectly after changing all the paths in the registry and registry_file tables. Thanks a lot
    – Tony
    Oct 12, 2015 at 8:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.