0

I just installed Drupal 8 in a subdirectory. I pushed all of the files to the directory, I installed Drupal with a minimal setup and and edited my .htaccess file to make Drupal work with my subdirectory. Now, it displays my website, but without any CSS or Javascript. It's just plain HTML text. How can I fix this problem?

closed as too broad by Mołot, kiamlaluno Oct 12 '15 at 5:50

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • That depends what is broken. From what you wrote, we can't even know if JS and CSS files are even there. And if they are, we don't know if Drupal generated entries for them. If it did, what HTTP status codes you got? What's in your logs? and so on, and so on. – Mołot Oct 11 '15 at 22:14
  • @Molot I'm not entirely sure how to find HTTP status codes. However, I have one warning in my logs. It says, Warning: Cannot modify header information - headers already sent by (output started at /homepages/8/d197535321/htdocs/KrisKendallSites/MatchFont/vendor/symfony/http-foundation/Response.php:361) in Drupal\Core\Session\SessionManager->destroy() (line 267 of /homepages/8/d197535321/htdocs/KrisKendallSites/MatchFont/core/lib/Drupal/Core/Session/SessionManager.php). Also, I think it might be worth mentioning that "index.php" keeps showing up in my addresses. – kriskendall99 Oct 11 '15 at 22:33
  • In Chrome, for example, hit F12, go to Network and reload page. – Mołot Oct 11 '15 at 22:43
1

Wow. I just solved the problem. I didn't realize that by default on a Minimal installation that the Stark theme, which is simply a plain HTML theme, was enabled by default. I switched the theme and now it works fine.

Not the answer you're looking for? Browse other questions tagged or ask your own question.