-1

To create a filter for my site I have installed following modules Search api, Search api db, Facet api

I followed the steps mentioned in http://www.webwash.net/tutorials/intro-search-api-part-1-how-create-search-pages and http://www.webwash.net/tutorials/intro-search-api-part-2-faceted-search for creating facets.

I have created server and indexed my fields. Then I placed the Facet blocks in the particular region. But blocks are not displaying. Please Let me know what mistake I have done. Thank You

closed as too broad by kiamlaluno Aug 18 at 20:37

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Have you cleared cache? Have you correctly set up the block in terms of visibility etc? – Potney Switters Oct 14 '15 at 8:58
  • Yes, I cleared all caches. I have set block to visible in all pages, but it is not displaying any wher @PotneySwitters – user50991 Oct 14 '15 at 9:01
  • As far as I understand it shouldn't be visible at all pages but only at /search-page – Potney Switters Oct 14 '15 at 9:11
  • I don't have search page how to display it in non search pages – user50991 Oct 14 '15 at 9:29
  • On admin/structure/block find the block and edit where you want it to appear. The search page is not "yours". As far as I understand and according to the tutorials you posted it is coming along with them. – Potney Switters Oct 14 '15 at 9:32
1

I experienced the same problem. I desperately seeked a solution or even a little hint on the Internet but finally I figured it out.

My problem was about the database privileges of the default mysql user (the one with credentials in the settings.php). Facet api requires Create Temporary Tables privilege to run properly. And as you can tell, my db user was not granted that privilege. Running the following commands on mysql console solved the problem:

GRANT ALL PRIVILEGES ON your_db.* TO 'your_user'@'localhost';
FLUSH PRIVILEGS;

I hope this helps someone..