In order to un-install a module I disabled and deleted the folder from the root module folder. Though I have deleted the module yet it's showing in module list page. Why is this? Am I doing wrong?


Simply find the module name, and write the following command in your command-line/terminal/console to disable the module at first (by considering that the current path in your command-line is the Drupal project root directory):

drush dis moduleName -y

then after the completion of the executing the above command, write the following command to uninstall the module:

drush pm-uninstall moduleName -y

If you have several modules, you can list their names. For example for three modules, you can write:

drush dis moduleName1 moduleName2 moduleName3 -y 
drush pm-uninstall moduleName1 moduleName2 moduleName3 -y

For uninstalling a module..

  1. Disable the module in Modules Page.
  2. Then uninstall module from Uninstall Page.
  3. Then delete the module files if you want.
  • after disabling its not showing under uninstall page
    – kashish
    Oct 15 '15 at 10:49
  • Not all modules have specific uninstall functions programmed in. A module will only show up on the uninstall tab if it has this feature. If it doesn't, skip this step and simply delete its files. from drupal.org/node/250783
    – Abin
    Oct 15 '15 at 10:51
  • 1
    did u flush cache...??
    – Abin
    Oct 15 '15 at 10:52
  • i could see one wonder, though i have deleted the module folder from root, if i go and check in admin->modules the module still exist, how could be possible?
    – kashish
    Oct 15 '15 at 10:55
  • check after flushing cache..
    – Abin
    Oct 15 '15 at 10:57

This may happen delete/remove the module before disabling in admin side....

Once again add and enable the same module... and Click checked-box to disable and click save configuration button... Now click uninstall link showed in top of the page and delete installed table...

Go to database system table...search module presence , if it is there delete rows and ensure....

Clear cache.... and ensure that cache table is empty....

Now run cron.php

Not the answer you're looking for? Browse other questions tagged or ask your own question.