I am going to test Drupal 8 RC, unfortunately my PHP version is too old.

It's asking for upgrade the version higher than PHP 5.5.9.

If I upgrade it to PHP 5.5.9 or latest version PHP 5.6.14, will it affect my current site that running Drupal 6?

Your PHP installation is too old. Drupal requires at least PHP 5.5.9. See the system requirements page for more information.

2 Answers 2


As reported in System requirements, Drupal 6 requires PHP 5.x, since support for PHP 4.x has been dropped by PHP maintainers; it is recommended PHP 5.2.5 or higher, but PHP 5.3.x and higher may produce errors or unexpected behavior.

So, yes, PHP 5.6.14 is going to affect your Drupal site, especially if you installed third-party modules or themes.

Bear in mind that Drupal 6 core code will not be changed, after Drupal 8 will get its first official and stable release. If they don't fix Drupal 6 code before, it will not get fixed. Once Drupal 6 code is not fixed, it is also probable third-party modules stop to get updates too.


Take a look to the specific version notes on PHP requirements to understand the compatibility:


Although PHP 5.3-5.5 are supported by Drupal 6, some contributed modules are not compatible with PHP 5.3 and higher many will throw E_STRICT errors and have other errors. Your Drupal 6 in 5.5 core will work ok. However, some contrib modules and themes may have problems.

You can configure your environment to have multiple php versions if you are interested. This tutorial helped me a lot to configure my environment in my Mac http://getgrav.org/blog/mac-os-x-apache-setup-multiple-php-versions

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.