1

For example, according to the Drupal module s3fs, I can -- to quote their README.txt :-

2b) If you don't have drush, go to to http://aws.amazon.com/sdk-for-php and click the orange "AWS SDK for PHP" button. On the page you're sent to, click the "aws.zip" link. Extract that zip file into your Drupal site's sites/all/libraries/awssdk2 folder such that the path to aws-autoloader.php is sites/all/libraries/awssdk2/aws-autoloader.php

So, yeah, that's effectively: downloading the library, and plonking it sites/all/libraries and that's it. But it doesn't work! I get:

Unable to load the AWS SDK. Please ensure that the awssdk2 library is installed correctly.

I've tried everything else in the README.txt : drush installer, specific version of AWS SDK, permissions...

0

How do I install a 3rd party PHP library in sites/all/libraries - can I just plonk it in there?

Answer: - It would appear you can, in some cases at least. With the example given the question, the problem was not whether or not a 3rd party php library could be just placed in the libraries folder, but rather some other unrelated issues that appear now to be resolved (the s3fs module make, coredumperror was very responsive today in helping me and they have updated their documentation). https://www.drupal.org/node/2596683#comment-10467823

Update

The "unrelated issues that appear now to be resolved" are that one of the setup procedures for the s3fs, as described in the README.txt, now work. By 'now work', I mean that I can install the module and do the described setup and use the S3fsStreamWrapper class provided with the module to read a file from an Amazon S3 bucket, more detail here https://www.drupal.org/node/2596683#comment-10467823 I had tried other approaches to reading S3 in Drupal, e.g. using examples elsewhere but was unsuccessful with those. But with this s3fs module I am now successful. With the s3fs module I had originally ran into issues whereby I got the aforementioned "Unable to load the AWS SDK. Please ensure that the awssdk2 library is installed correctly." error as stated in my question. But one of the maintainers of s3fs, coredumperror replied and updated the documentation as they discovered it had errors. So thanks very much to coredumperror on that, most appreciated. They have described what they changed in the above link. With this setup documentation updated and corrected, I was then able to use the s3fs module and read from a S3 file using the S3fsStreamWrapper provided with the module.

  • 1
    but rather some other unrelated issues that appear now to be resolved can you specify how this have been resolved? – Cyclonecode Oct 20 '15 at 3:48
  • +1 upvote @Cyclone thanks for the prompt, I have updated the answer as requested. Thank you. – therobyouknow Oct 20 '15 at 7:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.