3

I upgraded my Xampp to version Xampp 5.6.12 since Drupal 8 need PHP to be 5.5.9 or better. I checked out a couple of my Drupal 7 website under the htdocs dir. They are working fine.

I installed clean drupal 8 in the same htdoc dir under "newd8" folder. I used instructions so that I don't do make any mistakes.

The installation is fine and the default homepage came up at "http://localhost/newd8" and admin login account is working.

BUT clicking on any of the admin menu items, I get "page not found" drupal error. for example, if I click on "people", it goes to the link "localhost/newd8/admin/people" but I get a "page not found" page.

If I modify the URL to include index.php, thus "localhost/newd8/index.php/admin/people", it works. I get the right page.

This seem to be for all the pages. if I manually add "index.php" at the appropriate place, I get the required page.

I have modified the base URL in the setting.php file then its css file is not loaded properly even home page layout is totally disturbed

What am I missing?

  • check your server module rewrite file is unable?? – Adi Oct 20 '15 at 5:49
  • Also, I checked the httpd.conf I am still having th eproblem. Thanks the mod_rewrite is enabled. AllowOverride is "All" for / and for htdocs. – AjayR Oct 20 '15 at 6:31
  • I removed "aggregation of css and js" and that fixed the CSS issue in base URL but the original issue is still present. Any suggestions? thx – AjayR Oct 20 '15 at 16:15
  • What version of Apache is included with XAMPP? Enabling overrides is slightly different now in Apache 2.4. – mradcliffe Oct 20 '15 at 19:35
  • Apache 2.4.16. If there is a something I have to modify should that also affect Drupal 7? How should the "enabling overrides" be set to? Thx – AjayR Oct 20 '15 at 20:04
2

I fixed this.. Thanks to Sumit, I read the .htaccess file more carefully.. Inside the default .htaccess file that comes with the Drupal 8 download, around line 108, comments tells what to do if d8 is installed in a sub-directory instead of document root. I modified line to "RewriteBase /newD8" and now the site works. Even though the same comment is in the D7 version too, On the same Apache server and same document root, D7 works without the modification of the line but D8 needs the change. I don't know why. Because of Symfony perhaps?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.