0

I have just enabled clean URLs via admin panel, but now...

it doesn't matter what I click, all my urls redirect me to my home page.

you can try for yourselves by clicking any of the links: http://www.gelpalhano.org/drupal/

and none of the admin links work either, so I can't even disable clean URLs to make sure that is the problem. logout also does not work.

any light you can shed on this will be much appreciated.

4

It looks like you redirected the default user login page to somwhere else.

When I go to http://www.gelpalhano.org/?q=user, I get a HTTP 302 moved temp, followed by a 301 moved perm, followed by a 200 OK to http://www.gelpalhano.org/site/ (what appears to be your homepage).

Generally clean-urls would fail because your .htaccess if not configured properly, or because your web server is not configured properly. I saw your web host's headers say that the server is of type Microsoft, so I would not be able to suggest a fix for your particular setup (I only use the LAMP stack).

I can suggest however that to regain back access to your site, you substitute www.gelpalhano.org/?q=user for www.gelpalhano.org/?q=[the relative path to your user login page], and then once you've logged in, you can go to www.gelpalhano.org/?q=[the path where you turn on/off clean urls] and turn them off while you trouble shoot the issue. IMHO, this is a server setup issue, and I think you have more chances of having your issue resolved by researching and posting the same question at serverfault.com. Good luck and hope that my answer helps.

  • actually the problem does not seem with drupal itself, but is related to .htaccess, windows hosting and clean urls: I have a wordpress website which is in a sibling directory of the /drupal directory. This _public_html/site configured with .htaccess to redirect traffic on subpages to /site. so that's that. I'm moving servers. – marquito Feb 16 '12 at 11:11
0

I had this issue once, I copied a site from my testing environment (with clean urls enabled) to a testing environment (without clean urls). Clean urls shows as being ON in drupal settings even though the server wasn't supporting it at the time.

So I navigated to www.example.com/q?=admin/settings/clean-urls and turned it off. All my links (though unclean) began to work.

protected by Community May 3 '18 at 7:23

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.