1

When using a field collection feed import, I get this error.

An AJAX HTTP error occurred. HTTP Result Code: 200 Debugging information follows. Path: /batch?id=17839&op=do StatusText: OK ResponseText: Deprecated: Automatically populating $HTTP_RAW_POST_DATA is deprecated and will be removed in a future version. To avoid this warning set 'always_populate_raw_post_data' to '-1' in php.ini and use the php://input stream instead. in Unknown on line 0 Warning: Cannot modify header information - headers already sent in Unknown on line 0 {"status":true,"percentage":"64","message":""}

I have researched this issue and statistically came up with this solution: change in php.ini always_populate_raw_post_data = -1

I have changed that and also restarted apache.

I still receive that error. Does anyone have any thoughts to this?

1

You need to edit your php.ini and add or uncomment the following line:

always_populate_raw_post_data = -1

If you've still that error after restarting Apache, you probably edited the wrong file. So as admin, go to Reports/Status/PHP (at /admin/reports/status/php) and double-check your value for always_populate_raw_post_data and your php.ini path.

Note that the above setting will only avoid the warning, see: Changes to PHP-5.6 and this SO post.

0

As far as I know, it should be disabled.

There is an issue on this in the core Drupal queue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.