0

I have updated my project to the latest updates available using drush and suddenly found no field names and wrong field form url in

 admin/structure/taxonomy/%taxonomy_name/fields

As in the picture, have that issue happened before and how to fix

enter image description here

Edit: I coudn't also be able to add new fields and fatal error occurs

FieldException: Attempt to update an instance of a nonexistent field . in field_update_instance() (line 557 of /modules/field/field.crud.inc

despite being able to add/edit/delete terms

manage display return error

Fatal error: Unsupported operand types in /modules/field_ui/field_ui.admin.inc on line 1025

The issue is reported in issue nr 1275900.

It only happened with taxonomy and other entities work fine.

4
  • Have you run update.php? Oct 26, 2015 at 17:50
  • Yes I did, reverted back to another installation and still the same Oct 27, 2015 at 6:34
  • Perhaps roll back to your previous version (restore backup) and check that you have not defined any aliases for taxonomies before upgrading? admin/config/search/path
    – argiepiano
    Dec 7, 2015 at 13:52
  • the path module is not enabled, I have been reverted back to a previous DB and deployed changes via features but still don't see fields Dec 7, 2015 at 13:55

3 Answers 3

1

The problem solved by simply patching the field module file-> field.module function named field_extract_bundle

function field_extract_bundle($entity_type, $bundle) {
  if (is_string($bundle)) {
    return $bundle;
  }

$info = entity_get_info($entity_type);
if (is_object($bundle) && isset($info['bundle keys']['bundle']) &&     isset($bundle->{$info['bundle keys']['bundle']})) {
return $bundle->{$info['bundle keys']['bundle']};
}
//ADDED THAT ELSE
else{
  return $bundle->machine_name;
 }
}

the function tries to return the machine name of the entity as appeared above.

By doing some debugging I realized that the the object sent in the calling function field_ui_field_overview_form file->field_ui.admin.inc is n't the same as sent in drupal script before our continuous development in that project.

We added many other modules and edit configuration but the most related that I think caused that issue is features exporting the taxonomy vocabulary as the bundle object is the same exported in features so it may be some missing or conflict happened when deploying vocabularies with features

Please contribute your ideas!

4
  • Patching the core is a no go.
    – Elin Y.
    Dec 14, 2015 at 7:26
  • You are right but we didn't come to another solution yet Dec 14, 2015 at 10:59
  • Please check if your all other modules are up to date, especially those adding new keys to field definitions like field translations. (drupal.org/node/1275900#comment-7193756)
    – Elin Y.
    Dec 14, 2015 at 12:03
  • All modules are up to date and the core also is up to date Dec 15, 2015 at 11:20
0

I had the exact same issue, and the cause turned out to be a bug in the Commerce Services module. There is a working patch for this in the module issue queue: https://www.drupal.org/node/2024813#comment-7718289

-1
+50

Re-install website if possible.

You can find the solution for field_ui.admin.inc here: Manage Custom Display: Unsupported operand types in field_ui/field_ui.admin.inc

Edit field_ui.admin.inc line 1026:

$settings += field_info_formatter_settings($formatter_type);

to

$settings .= field_info_formatter_settings($formatter_type);

Open the error page, save it and then change back the code.

1
  • I did that patch but it only solves the error with manage display link only, my answer solves the error with both manage fields and manage display. I see its an issue with features module export vocabulary. Dec 12, 2015 at 13:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.