0

I have a D7 Website, and I am using entityforms module. I want to include those entityforms which I created in my custom content type so that users can submit their details. For example: a node with multi-field comments box. To achieve this, I added a field in custom content type of type "Entity reference" -> List. As an admin, I get to choose all available entity forms but not as a custom user role for which it shows "access restricted" while choosing entity form type.

Please guide.

  • Your question needs more details. Let me see if I got this right: you want to create a new Content Type that has an Entity Reference field. Do you want this field points to Entityform types or to Entytform submissions? What do you mean by "made visible"? Do you want the entire submission to be visible? The user to be redirected to the form? The form itself to become visible? The name of the form to become visible? As for the access restricted, go to /admin/people/permissions and set the right permissions for the new user role – argiepiano Oct 27 '15 at 14:49
  • Please check the updated one. – Gaurang Agrawal Oct 27 '15 at 14:58
0

OK, so I gather the problem you are trying to solve is the fact that a non-administrator cannot pick an entityform from the list? The solution: go to /admin/structure/entityform_types, choose "Edit" for each Entityform and be sure to check the boxes in "Roles" for "authenticated user". That way anyone logged in should be able to see and use the form.

  • Thanks a lot for this. Just one more question, what if I want users to see specific entity, meaning they shouldn't get option to choose. Is that also possible ? – Gaurang Agrawal Oct 27 '15 at 15:50
  • Go to /admin/structure/entityform_types, click Edit on each of the entityforms, and disable access for the specific Roles that should not be able to see that form. Then go to /admin/structure/types, click "Manage fields" for the Content Type that contains the Entity Reference field. Click on the link "Entity reference" in the "Field type" column. Click on the "Edit" tab next to "Field Settings" and choose the default entityform you want the user to see by choosing it in the "Default Value" fieldset. You may want to start a new question if this explanation doesn't completely help. – argiepiano Oct 27 '15 at 16:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.