0

Through views I am trying to show the account email address of any user to any user.

I have checked "Disable SQL rewriting", made sure the view didn't have any permissions, allowed anonymous user to view profiles. After all this it still won't show.

Note: I really don't want to create an additional field that is just syncs up this info just to show it. I want to show the actual field.

2
  • Are you trying to show the email address of other users to any user? What's not showing, the email address, or the view?
    – argiepiano
    Oct 29, 2015 at 22:13
  • That is correct Oct 29, 2015 at 22:27

2 Answers 2

1

Have you tried setting the permission so that anonymous users can view the profile of other users? Go to admin/people/permissions . See image below enter image description here

The view (for anonymous user):

enter image description here

5
  • Yep, maybe you missed it but I mention that in my original post. "allowed anonymous user to view profiles". User can view every other field but the email address. I am assuming this is by design in drupal core but I should be able to get around it with the sql rewrite as it completely ignores, permissions, roles etc. Oct 29, 2015 at 22:54
  • Sorry. Perhaps you can post what your View looks like (the left two columns of the administrative UI for Views) and also let us know if you are using any contextual filter, filter criteria or relationships. This perhaps may help people troubleshoot...
    – argiepiano
    Oct 29, 2015 at 22:56
  • Also, I just tried it myself. It shows the email of other users fine for anonymous user. No need to disable sql rewriting for me. So, this confirms that this is not a restriction by design in Drupal core.
    – argiepiano
    Oct 29, 2015 at 23:01
  • interesting. I wonder what I am doing wrong. thanks for your insight and proving me that it can be done. I should have tried on a clean install. instead i jumped to conclusions. i will investigate further. Oct 29, 2015 at 23:23
  • Goddammit. I had additional validation on the contextual filter (UID in URL) that was also checking role. removed it and it's working. now I feel like a fool. Oct 29, 2015 at 23:24
1

Once you done creating views, go to permission tab and check Role

https://i.stack.imgur.com/SWUU7.png

in the settings check anonymous, now the user will see the view.

1
  • I have removed and added all roles, permission requirements etc. The view shows but not the actual account email address. Oct 29, 2015 at 22:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.