1

I was updating my site to the new 7.41 release. I did the following as usual:

  1. Made a backup of files & database
  2. Put site in maintenance mode
  3. Deleted all files except the Sites folder
  4. Uploaded all new folders (excluding Sites)
  5. Attempted to update database

Once I did this I got the following error:

Fatal error: Call to undefined function ctools_include() in /home/cprids/public_html/sites/all/modules/geofield/geofield.install on line 14

This error is on every page, including the backend, so I'm completely locked out!

So I tried uploading my backup but still have the same error! I've emptied all the cache tables in my database as suggested in another similar discussion but have had zero luck. Any ideas on how to fix this would be really appreciated.

  • Can you run drush commands on that environment? Can you double check that ctools module in still there and enabled? – kenorb Oct 31 '15 at 19:07
  • Try temporary renaming geofield folder into geofield2, refresh the page and see if that would help. – kenorb Oct 31 '15 at 19:13
  • I don't use drush so couldn't tell you if it works I'm afraid. I cant access anything though, every page (including CMS) is down. – cprids Oct 31 '15 at 22:35
  • Changing to geofield2 just changed the error name to match it :( – cprids Oct 31 '15 at 22:35
  • Then temporary try to rename geofield.install file into geofield.install.bak and see if that helps. – kenorb Oct 31 '15 at 22:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.