0

I am hoping that someone can help me. I run a network of Drupal websites. They share the same code, but have different databases for each website.

This week, one of the websites began having a serious error -- any user other than me (UID #1) is restricted from seeing all of the content types and therefore cannot add any content, at all.

I've not made any changes to the websites that I am aware of that would cause this to occur. My other websites are all working fine and not having any similar issues.

As UID#1, I can do things normally, but if I masquerade as any other role or user, I am unable to add any content at all. When I mask as one of my higher level users who can see the content types, they are shown a screen that says no custom content types have been created.

I have looked at permissions and everything looks fine. Nothing looks any different than my other websites. I rebuilt the content access permissions and cleared the cache, but that did not help.

I've done some googling to see if I could find any similar issues and while there are a couple instances where content types have disappeared, they are all for earlier versions of Drupal and I assume do not apply to me. I am currently running Drupal 7.41 (just updated today).

Any creative suggestions on where to look next to try to resolve this issue are most appreciated. I'm truly stumped!

Heather

  • Did the problems start after updating to 7.41 or even 7.40? Or did you update any other modules in the last week? – longboardnode Nov 1 '15 at 1:26
  • The problems started sometime in the last few days. I just updated to 7.41 from like 7.39 to see if that would help with the issue. – Heather Nov 1 '15 at 19:54
  • Another thing to note: I have a role that provides full content administration, content type administration, etc. When I mask as this role, if I go to add content from the link in the administration menu, I get a page that says "You have not created any content types yet. Go to the content type creation page to add a new content type." but when I (using the same account) go to admin/structure/types, all of the content types are listed. I've checked the navigation menu, as I know that can mess with them showing up, but its fine. I've rebuilt access permissions. I'm stumped :( – Heather Nov 1 '15 at 20:11
  • I suggest you test the role by actually creating a dummy account and logging in to that account rather than masquerade... I've had some issues like that in the past with it – longboardnode Nov 2 '15 at 17:11
  • Thanks longboardnode for the advice. My user who I was masking as is experiencing the same problem. This morning I tried removing all add content permissions and re-adding them, thinking perhaps that might reset something, but alas, no luck. I'm not even sure what module would be affecting it in this way - as I said, I have 25+ additional websites running the exact same system, and have received the exact same updates and do not have the issue. This leads me to think its a problem in the database somehow? – Heather Nov 2 '15 at 17:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.