4

I'm running a largely default Drupal 8.0.0-RC2 site. At /admin/config/development/performance the "Bandwidth Optimization" settings for "Aggregate CSS Files" and "Aggregate Javascript files" are disabled, so I cannot change their state. Extensive though fruitless googling suggests this is unusual, but I'm stumped on where to start. I'm using the Drude environment for my site.

enter image description here

  • 1
    what version of Drupal 8 are you using? – No Sssweat Oct 31 '15 at 22:24
  • Drupal version 8.0.0-rc2 – Screenack Oct 31 '15 at 22:31
  • 1
    humm might be a bug, have you tried doing it on a clean install without installing any extra modules? – No Sssweat Oct 31 '15 at 22:45
  • Only core is currently enabled. Switched to the ironically-named "Seven" theme, checkboxes remain disabled. – Screenack Oct 31 '15 at 22:55
  • Disable JS and try again. I currently have issues #states going wild in RC2. – user21641 Nov 1 '15 at 10:19
6

There is a problem with the public directory, it is not configured or it is not writable. You can check this with drush:

drush ev "var_dump(is_dir('public://'), is_writable('public://'))"

Result should be:

    bool(true)
    bool(true)

If these two conditions are true, then the checkboxes will be available.

  • Yes this fixed the problem, thank you. I did see a UI notice about the "Public" directory needing to be configured, which it was, but I missed any notice about writable. That eval script is most helpful. Obviously, "Files" should be writable. Running drude turns some basic LAMP stack management practices around. – Screenack Nov 1 '15 at 12:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.