1

I have htmlawed text format filter. When I enable it for any filter that it is used by any CKEditor profile, it causes corruption for inserted Scald atoms in the CKEditor.

In other words, the following is a correct code for an image atom as shown in CKEDITOR source view:

<div class="dnd-atom-wrapper" data-scald-align="none" data-scald-context="sdl_editor_representation" data-scald-options="" data-scald-sid="8" data-scald-type="image">
    <!-- scald embed --></div>

After changing the text format to a format that it uses htmlawed and saving the node and then edit it again and switching to Rich Text Editor, I got the following code in CKEDITOR source:

<div class="dnd-atom-wrapper" data-scald-align="undefined" data-scald-context="undefined" data-scald-options="" data-scald-sid="undefined" data-scald-type="undefined">
    <!-- scald embed --></div>

This cause alerting an error message:

enter image description here

Just removing htmlawed filter makes ecerything works fine, but this is not an option for me.

I tried the following settings - in the screen shoe - for htmlawed:

enter image description here

However, it does not work as expected to preserve the scald attributes.

I alse tried to change the order of the filter by making it before or after Embedded atoms filter

Where is the mistake?

0

The solution, simply, is to change a Security setting of the CKEditor profile meant by this issue as follows:

1 - go to `admin/config/content/ckeditor/edit/(TheProfileName)

2 - In Security tab, goto Security Settings and choose Run security filters only when CKEditor is set to start automatically.

Of course, you have to notice that CKEditor in this profile is not started automatically.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.