-1

I have a local version of a site on my WAMP localhost. For some reason, and only in this site, the site's folder name won't appear in any internal link/url in the site (including administrative links). I would always need to add it manually with the keyboard, if I'll want to navigate anywhere. For example, if I'll manually type the address localhost/pharmatka/admin/structure/ and there left mouse-click on "Content types" or "Menus", I'll get a 404 not found error and the appearing address will be localhost/admin/structure/types or localhost/admin/structure/menu (without the "pharmatka" site folder name).

  • This problem does not occur other local sites --- it's unique only to that site, so the problem seems Drupal-originated rather than server-originated.
  • There aren't any similar problems with the online version of the site. *Clarn URLs are already activated.
  • The site has a fresh, unedited .HTaccess file.
  • The site seems not to have any customized modules.
  • The site's Drupal version is 40.1, all is updated. No DB updates pending. *I've tried to clear cache with Drush after all of the above - didn't help.
  • Try to use vHost instead of localhost/sitefolder. – Permana Nov 3 '15 at 7:41
  • Can try (would take me much time that I try to save) --- Why other sites in the same server won't require it, but this one allegedly does? Thank you!!! – JohnDoea Nov 3 '15 at 14:14
0

Commenting $base_url row in Settings.php (row 281 in my file) did the trick. For programming students like me, I Used a hash-mark (#) to do so. See the diff:

-- $base_url = 'www.sitesname.com';  // NO trailing slash!

++ # $base_url = 'www.sitesname.com';  // NO trailing slash

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.