0

I have a view generated by Views module and Entity Translation module enabled with the option "Enable language fallback" disabled. This should mean that if the language is not available the post should not be shown.

So if I'm showing the site in English and a post is only available in Italian it should not be considered.

In fact, in the view the post are shown as they have all fields empty.

I tried to check, inside, every field of the view

  • "Hide if empty"
  • "Hide rewriting if empty"
  • "Count the number 0 as empty" and even
  • "Remove whitespace" in rewrite result.

In the "Format" part of the view I choose "Grid" and "Fields" and in fields setting checked "Hide empty fields"

I tried to apply path 35 and 40, no fortune.

  https://www.drupal.org/node/1452820

Any ideas?

0

THE SOLUTION: after three days, i got that if you use entity translation in the 'entity' mode, you get some option in Views filters. In my case, only the field "body" in nodes was translatable and there was an option, among filter

Body's language

Setting this to "Current user's language" does the trick.

I heard about an option Node Translation to be set this way, but you don't have that option if you check as translatable only some field and not the whole node.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.