1

This question has been asked before but I see only D7 versions of the question, and none of their answers have helped me in D8.

I log in perfectly fine with Chrome or Firefox, but IE 11 redirects to the /user/1 page (or /user/2, or whoever you're logging in as) and states 'Access Denied.' If you enter incorrect credentials it states "unrecognized user/pass," but if you enter correct ones it just does the redirect and nothing happens. This is on a fresh install of D8 RC2 and what's worse is I can do a fresh install of D8 RC2 on a different server and IE 11 login works fine. It's something about my server that's causing this. I thought it might be cleanURLs but mod-rewrite is on for both servers.

D7 solutions seem to say, check settings.php and the cookie_domain or base_url variables, but those don't seem to be a part of Drupal 8.

I have cleared IE's cache/cookies about a thousand times.

0

I had the same issue but for Chrome and this was caused by the old cookies since it perfectly worked on the other web browser (Opera). When I've removed old cookies while being on that page, it worked as well.

If this doesn't work on one browser, but not on the other, definitely it's related to the invalid cookies.

If this doesn't work for all web browser, then most likely it's invalid cookie_domain setting in your services.yml file. By default Drupal automatically generates a unique session cookie name based on the full domain name used to access the site and it's sufficient for most cases. However if you're re-using across different subdomains, then you need to set your cookie_domain.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.