0

I am getting a "terminated" message from Drush ARD command after it runs awhile. This happens in a shared environment on bluehost. I checked the error logs accessible via cpanel, but found nothing. There are also no messages in the Drupal error log. I need more information that just "terminated" to solve this problem. Where are Drush error messages logged?

Putty commands -

    Using username "columck5".
Authenticating with public key "imported-openssh-key"
Passphrase for key "imported-openssh-key":
Last login: Fri Nov  6 10:51:16 2015 from 98.142.53.79
columck5@columbiablooms.org [~]# drush status
 PHP executable         :  /ramdisk/php/54/bin/php54-cli
 PHP configuration      :  /usr/php/54/etc/php.ini
 PHP OS                 :  Linux
 Drush script           :  /home5/columck5/.composer/vendor/drush/drush/drush.p
                           hp
 Drush version          :  7.1.0
 Drush temp directory   :  /tmp
 Drush configuration    :
 Drush alias files      :

columck5@columbiablooms.org [~]# cd /usr/php/54/etc
columck5@columbiablooms.org [/usr/php/54/etc]# ls -l
total 160
drwxr-xr-x 5 root root  4096 Nov  6 05:17 ./
drwxr-xr-x 5 root root  4096 Nov  6 05:17 ../
drwxr-xr-x 2 root root  4096 Nov  6 05:17 pear/
-rw-r--r-- 2 root root  1176 Jul 13 15:25 pear.conf
drwxr-xr-x 2 root root  4096 Nov  6 05:17 php.d/
-rw-r--r-- 2 root root 67071 Oct 29  2014 php.ini
-rw-r--r-- 2 root root 66936 Jul 23  2012 php.ini.rpmnew
drwxr-xr-x 2 root root  4096 Nov  6 05:17 rpm/
columck5@columbiablooms.org [/usr/php/54/etc]# nano php.ini
Error writing php.ini: Read-only file system
chmod gets the same error message
4

The Drush logs are emitted only to the console. Use --debug to get more information about what is happening.

Your ISP is probably deciding that your Drush command is taking too long, and are killing the process. Ask support at your ISP to determine if this is the case, and whether there is a way to increase the limit. Drush does not have any support this sort of limitation; it assumes that it is running in a shell with no time limits.

PHP can also be configured to apply a maximum timeout to your requests. To find out what php.ini Drush is using, run drush status. One of the lines will provide the full path to your php.ini file. Ideally, you should use a different php.ini for Drush than you do for your web server. Set the environment variable PHP_INI to point to the php.ini file that Drush should use. Copy your webserver php.ini to serve as a starting point, and then customize to suit.

The variable you are looking for is max_execution_time.

  • Thanks for the suggestion. I contacted Bluehost. They said there was a time parameter in php.ini. Can you give me a clue what they're talking about? – Sam Stamport Nov 5 '15 at 19:44
  • 1
    Updated answer. – greg_1_anderson Nov 5 '15 at 22:42
  • OK. I'm stuck with a permissions problem that I don't know how to fix. I've searched various forums. Some postings indicate this may be a hardware problem! I will edit my original question & try to post the putty commands I used. – Sam Stamport Nov 6 '15 at 18:37
  • 1
    Hardware problems can give the error message "Read only filesystem", but in your case, /usr/php/54 really is a read-only file system, because you are in a shared environment, and /usr is a global location. As I said in my answer, you should copy that php.ini to a location that you can write to (i.e. somewhere inside your HOME directory), and then set the environment variable PHP_INI to point to it. See man bash; put something like export PHP_INI=/home/yourusername/php.ini in ~/.bashrc. Then source ~/.bashrc, or log out and log in again. Drush status should then indicate your php.ini. – greg_1_anderson Nov 6 '15 at 19:17
  • Finally got it work. The thing that caused me to dive into this rabbit hole was that the Backup & Migrate module stopped working thus forcing me to look for alternatives. I successfully used Export on phpMyAdmin & Filezilla to make manual backups, but Drush is easier although it doesn't allow me to exclude database tables. It seems that learning Drupal is not enough. One also has to learn Drush & PHP. – Sam Stamport Nov 7 '15 at 16:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.