1

I created a role called site manager. This role is allowed to create new users. The problem is that users created by this user are not allowed to edit their contents. The Access denied is reported. But people created by the Administrator or people who signup for the site, can edit their content.

This is the permissions of site manager (for Users and content type Image):

enter image description here

and this one

enter image description here

Do any of you know why this happens?


UPDATE

After installing devel node access module I see this for a node which its author is z jafari

enter image description here

This user is allowed to delete its content but unable to edit it.

I also tried content access module, gave appropriate permission but it didn't work again.

closed as too broad by Yusef Mohamadi, Scott Joudry, kiamlaluno Dec 12 '15 at 15:56

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Do you problem exist yet? – Yusef Mohamadi Nov 18 '15 at 8:38
  • @zhilevan yes unfortunately – M a m a D Nov 18 '15 at 9:08
  • It seems some strange, I have suggestion only for debug purpose,please create another role, and set permission for it and try create a user by site manager and set that role to it.and tell me the result of it – Yusef Mohamadi Nov 18 '15 at 9:42
  • There are about 130 users who are created by site manager, and about 8000 contents are created by these people. No more user will be created, the problem is current users. – M a m a D Nov 18 '15 at 9:49
  • 1
    Ok, tnx for try it, I go lunch and think about it,come back soon and try to solve it with each other ;) – Yusef Mohamadi Nov 18 '15 at 9:54
1

Because they don't have any roles associated with them. You need to add a role to the new users giving them the permissions you want them to have.

  • But permissions of authenticated users are assigned to them, right? Authenticated users are able to edit their content. If their role wasnot Authenticated they wouldnot be able to create new content. – M a m a D Nov 6 '15 at 5:28
  • Ah, okay. Well in that case, it sounds like there are permissions problems elsewhere causing it. Have you tried clearing caches? – nvahalik Nov 6 '15 at 11:59
  • Yes, I guess as Tom said I should check for the author and compare the both kind of users – M a m a D Nov 6 '15 at 13:42
1

The "Configure Block" button is confusing me a bit. But anyways, check to make sure the users are listed as the author of the nodes and use the devel module to compare an administrator created user and a site manager created user.

Also, give the edit any node permission to authenticated and check what happens.

  • I used devel module, but actually there was no significant difference between them (except uid, time of its creation and some other stuff) . they all were assigned authenticated role – M a m a D Nov 11 '15 at 8:56
  • Very odd. Anything about it in the log? As a last resort, I'd use a rule to apply the authenticated role but doubt that'd help. I'm out of ideas. – Niall Murphy Nov 12 '15 at 5:14
1
+100

I think the problem is coming from the "site manager" permissions and he is not able to created a user with the correct ones.

Have you tried to add: "Access the content overview page" and "Administer content" to site manager?

Use this code and log in as one of the users:

  global $user;
  dsm(user_role_permissions($user->roles));
  • 1
    for no reason I gave 100 points to you ;) – M a m a D Nov 19 '15 at 19:48
0

I found the answer, I installed Edit Limit module to limit the time which a user can edit its comment. But I made a mistake by checking the checkbox of node edit.

many thanks to all the guys who helped me.

Not the answer you're looking for? Browse other questions tagged or ask your own question.