5

After updating the Views module from 3.11 to 3.13, I get an annoying text that says:

Leave blank for all. Otherwise, the first selected term will be the default instead of "Any".

enter image description here

Does anyone know how to remove it, besides using CSS?

This only happens in taxonomy term exposed filters.

Could it be a bug?

  • sometime it happens when you check the select all checkbox in the options checkboxes. leaving those checkboxes empty solve problem in most cases – Shabir A. Nov 10 '15 at 9:44
  • Looking like a bug, it says the exact same thing in the configuration settings, which is probably meant to be there only. – No Sssweat Nov 10 '15 at 10:03
  • 1
    Yes, it's a bug, you can track it here: drupal.org/node/2611958. – maciek Mar 21 '16 at 11:04
10

There is a problem with view 3.13. It happened due to this commit https://www.drupal.org/node/339384#comment-10548388.

Stated as:

Issue #339384 by colan: Added help text to keep the exposed filter terms list unset to keep unfiltered "Any" option default.

Apply this patch or revert your view back to version 3.11.

1

A quick, temporary "fix" is to use String Override module to hide this string. Just leave Replacement field blank or change to more applicable string.

1

I fixed this by "hiding" the helptext message from being displayed using CSS. .description { display: none;} I am not sure though if this poses any security risk. I think this is better than hacking Views or at least until patch is included to the current version (not the dev version).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.