1

Something is very strange. I have built 8 modules and they all work fine. When I installed the 9th one, it said "Configuration options have been saved" but when I access the path, I receive a "Page Not Found".

Tried : reinstalling module / clearing cache / recoding the whole module / renaming the module / using other path / rebuild permissions / ... even reinstalled the whole site and reconfigured it all.

All other modules are working but the 9th one fails.

I have seen many posts about this, but none of the options have helped me so far. Where did I make a mistake? Where can I look in the database to find out more?

7
  • 3
    My first guess is that you have some error inside the modules code. Would be nice if you could post the code. Try to set error_reporting(E_ALL) and ini_set('display_errors',true) and see if you get any errors when you save your configuration. Dec 21, 2011 at 23:06
  • indeed, an "off by one" error in a _menu() somewhere...any errors in any logs?
    – Jimajamma
    Dec 22, 2011 at 1:22
  • All error logging is always activated on my sites but none error ouput here. Been diving into the problem a little more. It seems that I can not register anymore ANY new module. All previous installed ones I can desinstall and re-install. But any new one, seems to result in an "OK" from Drupal but not working. What is the "off by one". Sounds interesting. What can I find out or clean in the database for that?
    – Droopy
    Dec 22, 2011 at 15:52
  • btw, I am on a Drupal 7.10 system and all modules are uptodate.
    – Droopy
    Dec 22, 2011 at 16:37
  • OK, here is some HOT info. I just disabled about 15 modules which I don't use yet or are not essential. And guess what... I can register again the module and it works fine. How to find out now which one it was? I going to give list of the one I disabled, it can be handy for future reference:
    – Droopy
    Dec 22, 2011 at 20:29

2 Answers 2

1

hook_menu() had 3 entries: one for entering parameters, one for showing the question selection, and one for showing the answers.

The error was in the second page, which still pointed to an old (disabled) URL.
The very very strange thing is that the module didn't show even the first working path and that there was no error of it.

0

@Droopy apart from checking the error reporting and logging ...if the module defines its own tables in an install file, delete them after the uninstallation in case its not written in your hook_uninstall and check if the tables are being created properly during the reinstallation of the module (provided you have full permission to access the DB)..also if possible delete the entry for your module in system table and reinstall the module... that worked for me in similar occassions..also request you to tag your drupal version in the question to help identify similar issues to other users..

1
  • OK but the site didn't let me add the version. nr core = "7.x" version = "7.x-8.0"
    – Droopy
    Dec 22, 2011 at 15:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.