0

I've enabled my WYSIWYG editor for my authors on my site so that it uses filtered HTML format (using better formats module to ensure they use that text format).

However, while testing I note that when I use the WYSIWYG editor to input content, like new lines, tables, etc...the formatting doesn't actually 'take'. Certain things like links get set ok and bolded items...but not all the tools available in the CK editor WYSIWYG are showing correctly when the item is unpublished or published. When I go back to edit the item the HTML is all still there...but for some reason it doesn't display as if it's using the HTMl.

Thoughts on this?

1

You need to go to

/admin/config/content/formats/filtered_html

and add the html tags under allowed tags.

enter image description here

Then under Limit Allowed html Tags add <form> <input> into the list.

IF The above does not do it

go to:

/admin/config/content/ckeditor/edit/Advanced (for Filter HTML)

Then under Advanced Content Filter, select disabled.

enter image description here

  • I'm using ckeditor (not the module version) so this wasn't applicable to me - thanks though. – Sage Nov 18 '15 at 1:01
1

Filtered HTML format restrict some HTML tags, inspect or check source code of your text and see what is new line converted to.

Few guidelines for WYSIWYG editor:

  • Try Full HTML format
  • Check with permission on HTML profiles, on this path: admin/config/content/formats
  • Check your jQuery version, use jQuery update module
  • Check is there any JS error on console

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.