0

I'm trying to install 8.0 RC4 on CentOS6 with Apache2.2.15 and I'm being stopped by this error message:

Apache/2.2.15 The minimum version of Apache needed to run Drupal without mod_rewrite enabled is 2.2.16. See the enabling clean URLs page for more information on mod_rewrite.

I've made sure to have this on httpd.conf: AllowOverride All

And mod_rewrite is in fact being loaded correctly. I tried httpd -M | grep rewrite and I get: rewrite_module (shared)

I even tried copying the htaccess sample into httpd.conf. I restart apache, and I always still get the same error. Does Drupal 8 simply not support this version of Apache? Could it be the fact that I'm accessing the site via the server's IP rather than a host name?

I tried upgrading to Apache 2.4 but that was an ordeal since the package manager doesn't provide it and the end result gave me even more problems.

Any advice?

Edit: I've installed a wordpress site and tried using SEO friendly URLs, everything works fine. Clearly mod_rewrite has to be working.

1

If you are sure that mod_rewrite is enabled and working you could try to get past the system requirements check if you change the url during the step "Verify requirements" like this:

Standard URL like this:    
core/install.php?langcode=de&profile=standard
change it to:
core/install.php?langcode=de&profile=standard&rewrite=ok

You add

&rewrite=ok

to the url. This will normally be done through .htaccess. Then reload the page or click try again and you should get past this warning.

But it seems that something is not working as expected with your mod_rewrite, so you might encounter trouble later on.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.