0

I have a drupal in http://nuevo.drupalsite.com.mx and is working perfect, but when I move drupal to my root folder and run http://drupalsite.com.mx the homepage is work but internal paths is not working, is to say:

  • drupalsite.com.mx =>is work!
  • drupalsite.com.mx/user =>is NOT work!
  • drupalsite.com.mx/products =>is NOT work!
  • drupalsite.com.mx/service => is NOT work!

All paths show error 404 and I cant into the user /admin page.... Help me please!

4
  • Hi, it's very likely that you just haven't configured your web server properly for rewriting URLs following the move - the duplicate has details about that. The simplest test is to go to "example.com/?q=user". If you see the user login page, it's definitely a clean URL problem. If not, you'll need to do some more digging to find out what else is wrong with the server config. It's hard to see how anyone could guess from here, as it could be caused by a bunch of different unrelated problems
    – Clive
    Nov 19, 2015 at 10:29
  • You can you these urls like : drupalsite.com.mx/?q=user, drupalsite.com.mx/?q=products, drupalsite.com.mx/?q=service. You are missing to enable clear url, if you enable this then you can normally user above urls without entering '?q='
    – user50292
    Nov 19, 2015 at 10:33
  • Thanks Clive & Arti, Yes, I can see this URLs drupalsite.com.mx/?q=user but I am new in drupal, this is my first website and I Don´t know how to resolve this problem??
    – cfranco
    Nov 19, 2015 at 16:02
  • Thanks Clive & Arti, I´ve restored the .htaccess file and it worked again!!! Thank you very much
    – cfranco
    Nov 19, 2015 at 16:13

0

Browse other questions tagged or ask your own question.