0

I have ris files of citations to upload, and despite having titles mapped correctly at admin/config/content/biblio/iomap/edit/ris -- T1 goes to Title, I get nothing but "untitled" nodes. I am using version 7.x-1.0-rc7. Some other data seems to populate appropriately, but looking at logs, many things aren't, so it's more than just titles. I have a large number of errors for a number of fields along the lines of:

Notice: Undefined property: stdClass::$title in _biblio_ris_parse_line() (line 357 of C:\wamp\www\mysite\sites\all\modules\biblio\modules\RIS\biblio_ris.module).

Thinking there might be something wrong with the data, I created my own simple ris file and tried an example file that I found online. I had the same problems with all of them.

I tried the dev version and have the same problem.

Any help would be appreciated.

0

after finding this comment, I changed two lines in biblio_ris.module:

339 from

$node->biblio_pages .= ($tag == "SP") ? $data : " - " . $data;

to

$node->biblio_pages = ($tag == "SP") ? $data : " - " . $data;

and 357, from:

$node->$field .= $data;

to

$node->$field = $data;

It works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.