2

I did a fresh install of Drupal 8. Everything had a nice style while installing, but when it was done, there was no CSS anymore. Did the installation change some file rights?

  • I tried flushing the cache
  • I did check if the core/theme folder has CSS files in it
  • I did a re-install, but again there is just raw HTML

I checked and it looks like I have an HTTP/1.1 500 Internal Server Error on all CSS and JavaScript files.

Update: The issue is with the .htaccess file in /sites/default/files/.htaccess I changed the permission of the file to 644, then once changed, i did edit the file via the file manager and commented out these lines:

#Options -Indexes -ExecCGI -Includes -MultiViews php_flag engine off

It works now but is tis a safe way to do it?

  • try flushing the cache. Check if the core/theme folder has css file on it. I don't think file rights should affect css from being outputted as long as the css got uploaded. If not, try installing again. – No Sssweat Nov 20 '15 at 22:49
  • Inspect the page source for the style sheet source, copy url and try to navigate to it in new browser window. Take it from there. – J. Reynolds Nov 21 '15 at 5:22
  • See if your files directory has proper permissions(is writable by drupal). – user21641 Nov 21 '15 at 10:54
  • What is the contents of the 500 response? If you switch error reporting on from config > development > logging you should see the error in the response – larowlan Nov 21 '15 at 21:25
1

In my case, I was getting this in the apache error log:

.../sites/default/files/.htaccess: Option MultiViews not allowed here

Checking .htaccess, I found:

# Turn off all options we don't need.
Options -Indexes -ExecCGI -Includes -MultiViews

Even though it's turning MultiViews off, it's still not allowed, and removing it fixed the CSS. Enabling sites to set it int he global apache config would also resolve it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.