This is a follow up to this question. If I go to admin/store/products/classes, then I can only create new content types:

enter image description here

The problem is, I have another content type, called "product", which I need to set as an UberCart product. And I create this class in ubercart that has now resulted in a new content typed called "Basic Product". When all I really want is for the existing product to be considered as an actual product.

When I edit the "product" content type, I can see it doesn't have the same options as the "basic product" content type:

enter image description here

So the question is: how do I make my EXISTING "product" content type an Uber Cart product? I checked under classes and that only seems to work if you want to create a NEW content type.


Have you simply tried to put the machine name of your existing content type in Class ID, and its human name in NAME ?

I've had such problem 3 years ago, and I solved it so. More, for tests purpose I've just created a foo content type. Then I added the Class ID foo, and it has been mapped with foo content type.

  • I did, and it threw another error. But it seems unrelated. So yes, it seems to just work by doing that. Thank you! :-) – coderama Nov 30 '15 at 18:06
  • Glad to know you had no worse trouble ;) – Kojo Nov 30 '15 at 19:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.