0

When I tried to import the data it's showing as "The chosen directory does not exist and attempts to create it failed". What exactly is this I am not getting.

10
  • 1
    How do you import it? can you show you code? Keep in mind that you can only do that in the public directory.
    – GwenM
    Nov 23 '15 at 11:33
  • @Namari: whats the difference between public and private directory....
    – neethu
    Nov 23 '15 at 11:34
  • 1
    It needs to go into the sites/default/files directory and not anywhere else. drupal.org/documentation/modules/file
    – GwenM
    Nov 23 '15 at 11:36
  • as u said i tried in my localhost its working but when i tried to do same in my company dump it showing error
    – neethu
    Nov 23 '15 at 11:37
  • 1
    Is it a read and write directory? check the permissions that might be the issue. Your webserver need to have read and write access to that directory.
    – GwenM
    Nov 23 '15 at 11:39
1

I got the same error when I tried to create a Feed type using Feeds module. I selected the option upload file in Fetcher dropdown, and CSV in parser. And in Fetcher settings, in the textbox Upload directory, I put public://feeds.

To solve this error, I created a folder feeds in the location .../web/sites/default/files and changed the permission of the feeds folder to 777. And when I clicked on Save feed type, I no longer got the error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.