I am using Aquia Dev Desktop. I have a MySql database dump that is too big to upload into Aquia Dev Desktop. What are my options? I am using a Mac, so would appreciate Mac based options

Steps I have tried:

I think the problem is the cache table. If I could empty (not delete) this table, I should be able to upload it into Acquia Dev Desktop.

1) Downloading MySQLWork Bench to delete the cache table. MySQl Work Bench has a Data Import option. However, it requires the password of the Acquia Dev Desktop, which I don't have.

2) Downloading Sequel-Pro to delete the cache table Again this requires the username/password of the database.

  • Importing data isn't related to Drupal and we don't recommend software here...the Software Recommendations site might actually be a good fit for this since you have specific requirements, just check their help center to be sure first
    – Clive
    Nov 26, 2015 at 16:43
  • @Clive. 1. The problem is the cache table, which is related to Drupal because it is made by Drupal. 2. I'm not actually looking for software, just a method for removing the cache table. If you still think it is off topic, then I will try the link you posted.
    – big_smile
    Nov 26, 2015 at 16:51
  • I do think it's probably off topic @big_smile, but less so than when I closed it. I guess there's an outside shot of there being a Drupal-y solution to this, let's see what happens. Though I have to admit I'm struggling to see what shape a Drupal-related solution would take. Especially as it seems you've already solved it, except that you don't have a username/password - Drupal can't help you to recover those. Apologies for messing you about
    – Clive
    Nov 26, 2015 at 17:57

2 Answers 2

  1. configure Mysql my.ini

change the value of myisam_sort_buffer_size from 8M to whatever your sql size is.

I will say if your file size is 100 change the value to myisam_sort_buffer_size = 156M.

  1. Restart your mysql.
  2. using terminal navigate to mysql bin directory
  3. run the command: mysql -u username -p yourdatabasename <yourmysqldatabasefile

enter the password for the user, if there is no password the user than just press enter.


Unfortunately, it doesn't seem possible to fix this when using Aquia Desktop as the username/password for Aquia Desktop are unknown.

In future, the best option is to install the Back up and Migrate module: https://www.drupal.org/project/backup_migrate

This will automatically clear all the cache tables each time when backing up. You can, of course, empty the cache when using PHPmyAdmin, but this module is more foolproof as you don't have to worry about forgetting.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.