0

I added a new field (field_acc_guide) to my user accounts in a feature. Then, I reset my dev site by overwriting the database and files with those from production. However, this results in an error:

WD php: PDOException: SQLSTATE[42S02]: Base table or view not found:     [error]
1146 Table 'pantheon.field_data_field_acc_guide' doesn't exist:
SELECT t.*
FROM
{field_data_field_acc_guide} t
WHERE  (entity_type = :db_condition_placeholder_0) AND (entity_id IN
(:db_condition_placeholder_1)) AND (language IN
(:db_condition_placeholder_2)) AND (deleted =
:db_condition_placeholder_3)
ORDER BY delta ASC; Array
(
    [:db_condition_placeholder_0] => user
    [:db_condition_placeholder_1] => 0
    [:db_condition_placeholder_2] => und
    [:db_condition_placeholder_3] => 0
)
 in field_sql_storage_field_storage_load() (line 412 of
/srv/bindings/3e6587f55074463ea17292eda4e1ac67/code/modules/field/modules/field_sql_storage/field_sql_storage.module).

I have tried re-copying from production into dev but the same error occurs. I try to reset the feature (that contains the field) with Drush in order to create the field but I continue to get the same error.

How can I prevent the error so that I can revert the feature so that my site doesn't crash?

  • I've certainly done this and not had the error, so something must be wrong. Does the feature have both the field_base and field_instance? You may have to roll back the feature to the previous version and start over. – cleaver Nov 29 '15 at 0:54
  • @cleaver Yes, I have added both the base and instance. – Patrick Kenny Nov 29 '15 at 4:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.