0

I'm new to Drupal 8.

I tried to do some batch process (for example installing modules or importing language files).

I got access denied for example on this address : http://localhost/en/batch?id=17&op=start

I tried to investigate and debugging and find out in the file batch.inc

$request->get('id')

is Null

That means id=17 is not working.

What am i missing? Is it related to my Nginx server block config?

2
  • If you get access denied then that is a new response so I doubt you'll be able to access data from previous request. There is some magic going on with 404 and 403.
    – user21641
    Nov 30, 2015 at 10:56
  • 1
    Those URL are only accessed during a batch operation. When batch is done or interrumpted the URL won't work. You shoud explain in more detail the workflow you follow to see the error (ehat actions you do, which pages you see, is the batch process completing any steps or failing before startings, etc).
    – sanzante
    Nov 30, 2015 at 15:33

1 Answer 1

0

It was related to my nginx config and fast cgi params

using apache instead of nginx temporarily fixed he issue

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.