0

I installed minimal version of latest stable Drupal 8. It does not include any HTML text formats so I had to add my own custom Full HTML text format next to default Plain Text.

It also doesn't include any content types, so I had to create my own Basic page content type with Body field.

When adding/editing content under body field it doesn't show the Text format field drop-down and I cannot select neither out of two formats, it just loads up some default CKEditor.

enter image description here

Also with minimal installation it doesn't include Administrator role. So I did create my own custom Administrator role and gave it all permissions, including under Filter, but still no effect, even though I'm user/1.

How do I get Text format working/displaying on Minimal installation?

  • What's the question? – kiamlaluno Dec 1 '15 at 16:54
  • How do I get Text format thing? – Optimus Prime Dec 1 '15 at 17:09
1

Look in the standard profile:

core/profiles/standard/config/install

In comparision the minimal is rather empty:

core/profiles/minimal/config/install

You can take this yml-file for the text format, put it in the sync-folder and import it:

core/profiles/standard/config/install/filter.format.full_html.yml

But probably you need much more configuration, did you consider to start over with the standard profile?

  • You have to chose full install just for text format? Shouldn't there be a documentation stating what you lose on minimal installation then? I chose minimal because full D8 is slow as hell on windows localhost. – Optimus Prime Dec 1 '15 at 17:47
  • @OptimusPrime Drupal is an open source project. You're free to contribute any lacking documentation you see fit. The Community would thank you. – tenken Dec 1 '15 at 17:57
  • Then my question would be what's the point of text format filters feature and settings in Minimal profile if you cannot use it anywhere? I see it as a bug, if you can create filter formats, but cannot use it, because Text format field is missing. – Optimus Prime Dec 1 '15 at 18:07
  • If you create them then they should definitely show up. Might be a caching problem, try to clear all caches and if that solves it, create a bug report about that. If that doesn't ,also create one. both with detailed steps on how to reproduce. – Berdir Dec 1 '15 at 22:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.