I'm rebuilding a commerce site and I'm trying to use Commerce Feeds to bulk import my products. The issue that I'm having is that the node parser isn't mapping to the product SKU which is creating incomplete product displays. The title is imported, but most of the product display is empty until you manually set the SKU to the correct product. Doing this manually defeats the purpose of bulk importing them in the first place.

I even tried to import the working importer from my other site, but there the SKU mapping is labeled "Missing."

So, 1) what can I do that I don't have to manually set the SKU's for my products?

2) why is the product sku missing from the mapping options?

1 Answer 1


Found a similar problem in one of the issues, switched the dev version which solved my problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.