0

I have a user registration page where in being a admin i have assigned particular to user.

But now when a users edits his/her own profile, all the available roles are showing up and in fact users can assign roles by themselves and save that. Such users can even edit as admin.

This is obviously not correct, so what should I do to correct that?

enter image description here

closed as unclear what you're asking by kiamlaluno Dec 4 '15 at 11:11

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

0

In /admin/people/permissions/roles Add a new role, Ex call it Admin2

Then assing that user the Admin2 role

In /admin/people/permissions for the Admin2 Column.

Under User:

  • Administer permissions
  • Administer users

Make sure both of these are unchecked.

For all the other permissions, basically you check mark all the stuff you would like to allow Admin2 to do and leave uncheck all permissions you don't want him to have.

  • please tell me where to assign the roles , i have roles and when walk through people->permission here how to asaign? – yuvika Dec 4 '15 at 10:38
  • and under user administer permission and administers users are unchecked – yuvika Dec 4 '15 at 10:39
  • you need to go to /admin/people then click edit button that corresponds to the user name. Then under Roles check mark the role you want them to have and save changes. – No Sssweat Dec 4 '15 at 10:41
  • if i walk through admin people i will find list of users ->if i click on edit than all the roles i could see?user should see only his role assigned,now after disabling the permission when i login as a user the assigned role by admin is only not visible for me – yuvika Dec 4 '15 at 10:50
  • Go to admin/people/permissions as No Sssweat said. And assign proper permission as @ No Sssweat mentioend. Just keep those settings enabled to administrator. Leave unchecked for all other users. – dev.patrick Dec 4 '15 at 10:54

Not the answer you're looking for? Browse other questions tagged or ask your own question.