0

I have created a webform block. After I enter all the info in the webform, I clicked the Submit button. Nothing happens. Do you know why the Submmit button is not working?

This webform block's submit button works: http://godrupal.info/?q=contact-us

Actual webform node's submit button works : http://godrupal.info/?q=node/16. Then I created block of the node/16 but then this webform blocks's submit button does not work: http://godrupal.info/?q=plan-an-event

1

if you look into your console log you will see the following errors

enter image description here

this happens when you hide a required field.

I had a look at your markup and found that you have the above 4 fields display set as none; and at the same time also has attribute required.

So remove the required attribute or apply novalidate on submitting form.

  • Thank you. After i display the fields, submit button is working. I did make the address field not required. I still have the same issue. I do need to hide the fields. I did look at the form settings of the webform and i did not see where to select no validate on submitting form? – learn4ever Dec 4 '15 at 20:31
  • Can you remove the required attribute from the hided field? – Shabir A. Dec 4 '15 at 20:36
  • <form action="" novalidate> like this. – Shabir A. Dec 4 '15 at 20:39
  • I did make the address date field not required now. It is working. I cant make the month/day/year not required bc I used date field. But the problem is that people can submit the form without entering the date. Option1- I can make the field required and display all fields Option2- I can make the field not required then hide the fields then I dont know where to enter form action = "" novalidate. Is it need to be entered in tpl file? I am still new. My two requirements: date must be required and month/day/year field must be hidden. – learn4ever Dec 4 '15 at 21:08
  • try this in your template.php function THEMENAME_preprocess_webform_datefieldname(&$variables) { $variables['element']['#attributes']['novalidate'] = TRUE; } – Shabir A. Dec 4 '15 at 21:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.