0

I've installed Drupal 8 and setted the site to be in Hebrew. It was changed to Hebrew, but from some reason, all the management system area\navigation\menues themselves were also translated to Hebrew. Such a thing never happened to me In Drupal 7.

In Drupal 7 when I was installing sites and setting the language to Hebrew, I would only have everything moving to the right (Hebrew is an RTL language) and the usage in the language became available, but I never, ever, had all the site translated automatically.

Is there a way to allow Hebrew without translating every part of the site to Hebrew?

enter image description here

  • There is no need to put Drupal 8 in the title. This site is about Drupal, and we have a tag for Drupal 8, 8, which is always visible where the question is visible. – kiamlaluno Dec 8 '15 at 4:15
  • Are you sure you weren't using drupal.org/project/admin_language on your Drupal 7 site for force the Admin to something? – mpdonadio Dec 8 '15 at 14:30
3

You can configure the administration language seperate to the content language by setting:

/admin/config/regional/language/detection:
Account administration pages: enabled

If you want to force this, set this setting at the top of the list.

Then there is in the user configuration of admin's the option to set a different language for the site and the administration pages language.

For other roles, just set the permission "Use the administration pages and help" to allow this setting to appear on the user page.

| improve this answer | |
  • The problem with that approach is interface parts that are used outside the administration pages (for example admin toolbar) still gets translated which is very annoying. Benia's answer prevents that. – Sinan Erdem Sep 11 '17 at 11:48
1

Here is what I did to solve it:

  1. I've deleted the Hebrew language setting to re-create it later.
  2. I've un-installed the module "Configuration translation" and than the module "Interface translation".
  3. I Re added the Hebrew language as supported, and setted it as default.

Now the site was supporting Hebrew but no longer translated everything to it automatically.

| improve this answer | |
  • This only works, until you update the Hebrew language. That is loading the .po-file for that language to /sites/default/files/translations/ automatically or manually. If you want to remove the translation again, you don't have to uninstall the modules, you can simply remove the .po-file of one language. – 4k4 Dec 8 '15 at 10:07
  • Sorry, I did not read your question fully, you can do this, use the Hebrew language without the two modules, this will work. – 4k4 Dec 8 '15 at 10:47
1

If you choose a language at Drupal 8 install, then the interface will be translated by default. Useful for users who do not speak English. The translations are automatically imported from localize.drupal.org.

If you do not want the interface to be translated just uninstall the "Interface translation" module.

If you want Interface translation, but do not want to import translations from localize.drupal.org, then restrict the Translation source. Translation files with translated interface text are imported automatically when languages are added or when modules or themes are enabled. On the "Interface translation settings" page (/admin/config/regional/translate/settings), the "Translation source" can be restricted to local files only.

| improve this answer | |
0

My solution was to remove the second language (in my case Turkish). Then I added a custom language with code for example "mytr". The only downside is your translated pages are now accessible from www.example/com/mytr/... instead of www.example.com/tr/...

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy