0

I've this configuration:

  • Fedora Core 21 (64bit)
  • vsftpd: version 3.0.2
  • Drupal 7.41

I have a unix user called user1 who has home dir /home/user1 and Drupal root is at /home/user1/www

The Drupal temporary directory is at /home/user1/tmp

I'm trying to install the Corporate Clean theme using the update manager but it fails giving this message:

corporateclean Error installing / updating File Transfer failed, reason: Cannot move /home/user1/tmp/update-extraction-5345b836/corporateclean/comment-wrapper.tpl.php to /www/sites/all/themes/corporateclean/comment-wrapper.tpl.php

I checked ownership and permissions of /home/user1/tmp/update-extraction-5345b836/corporateclean and it's owned by apache and permissions are like so:

755 drwxr-xr-x 7 755 apache 4096 Dec 9 07:05 corporateclean

Is this the right permissions / user for the extracted directory by the update manager? The owner / permissions is causing the issue and not allowing the move.

1

After reading Enable FTP on your server i applied the changes as mentioned in the /etc/vsftpd/vsftpd.conf file.

The changes applied are

Linux Instructions (UNSECURED):

Step 1:  sudo  yum  install  vsftpd

Step 2:  sudo emacs /etc/vsftpd.conf
Uncomment these settings:
listen=YES
local_enable=YES
write_enable=YES
local_umask=022
anon_upload_enable=YES
anon_mkdir_write_enable=YES

Step 3:  sudo service vsftpd restart

i then changed the ownership of the drupal root to apache user

chown -R apache:apache /home/user1/www

and this fixed the problems for me. am able to install themes via FTP method.

Please note - the method i've used is potentially insecure. Don't use on production server.

Thanks.

Yashesh

  • Your answer will be useless if link to documentation will ever change. This is considered low quality here. – Mołot Dec 9 '15 at 16:04
  • am a newbie here. thx molot for your feedback. i've edited the answer. – Yashesh Bhatia Dec 9 '15 at 16:37
0

I am not sure it will help you or not. Please use the following command to sure the directory owner permission.

ls -l

If you see the www-data missing then you can try the following command

sudo chown www-data:www-data /home/user1/tmp
  • thx imran the directory /home/user1/tmp is owned by apache:apache. drwxrwxrwx 2 apache apache 4096 Dec 9 08:30 tmp – Yashesh Bhatia Dec 9 '15 at 8:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.