0

This question already has an answer here:

I've created a view to display items with a certain content type. I'd like to display the terms in an associated taxonomy along with them. Many of these nodes have more than one term selected.

The output currently displays nodes one time for each taxonomy term assigned. How can I adjust this so that it displays each node once with every term associated with it?

Thank you!

marked as duplicate by Mołot, Scott Joudry, Shawn Conn, Krishna Mohan, kenorb Dec 11 '15 at 13:29

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • are you using term reference field in Drupal 7? – Shabir A. Dec 10 '15 at 20:03
  • @ShabirA. I'm have a relationship to the taxonomy I'm using and a "Has Taxonomy Term ID with Depth" Contextual Filter. Whenever I try to add a term field it starts displaying each node more than once for each term. – Vecta Dec 10 '15 at 20:10
  • use distinct will solve the problem. – Shabir A. Dec 10 '15 at 20:14
4

You can apply GROUP BY or DISTINCT by enabling views aggregation settings to remove duplicate records.

  1. Go and edit your view
  2. In Advanced » OTHER section by enabling Use aggregation: Yes
  3. In FIELDS or FILTER CRITERIA section, select and apply Aggregation settings for which fields you want to group by or distinct.
  • I discovered that I was sorting based on the TID and not the Entity ID. Changing this solved it. Thank you for your help! – Vecta Dec 10 '15 at 20:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.