Up until recently, I've been using version 6 of drush, and it worked like a charm. Since I started delving into Drupal 8, I installed drush 7 on my Mac using the install instructions (using Composer) for global drush. Initially, it was fine, but whenever I try to run it now, it just hangs. When I run it with -d, it gets this far:

Using the Drush script found at /Users/steve/.composer/vendor/drush/drush/drush.launcher using pcntl_exec

Running which drush shows the correct path (/Users/steve/.composer/vendor/bin/drush), but like I said, running drush by itself or with any other command, it just hangs. From what I understand, the only error logging is to the screen, but since there's nothing being displayed to the screen, I'm not sure where to look. I don't have memcache installed (unlike this guy), so I know that's not the problem. Any suggestions?


UPDATE: I am using Drush 8 not Drush 7 (I fixed the title accordingly). After a couple days, it's back to hanging again, and even using -d shows nothing.

  • I have the same using Drush 7 :-(
    – lrkwz
    Commented Sep 21, 2016 at 11:19

2 Answers 2


Only Drush 8 is compatible with Drupal 8. See http://docs.drush.org/en/master/install/#drupal-compatibility

  • I updated my post (and title) above - I am actually using Drush 8.
    – wonder95
    Commented Dec 14, 2015 at 22:01
  • Are you chasing Drush master? Alternatively, what Drush version are you using? ($ drush --version). You could also try and quickly test with the PHAR alternative to rule out any issue with your composer install.
    – anavarre
    Commented Dec 15, 2015 at 9:26

Well, it looks like the Stack Exchange effect (post a question, and the problem is solved) worked. Actually I just restarted my computer (the Microsoft method of support), and it's now working fine.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.