0

I am getting the following error on a white page after using VBO and Drupal Commerce -

*Call to a member function aggregate() on a non-object in
.../sites/all/modules/contrib/views_bulk_operations/views_bulk_operations.module on line 764*

I upgraded to Drupal Commerce 7.x-1.x-dev and am running the latest version VBO and Commerce Stock

Whenever I try to perform any Bulk operation, like deleting a bunch of products or changing the order status, I get the error

I have looked at the issue, which discusses an issue with Commerce Stock and empty fields, but the solution found doesn't apply because all the stock levels have values.

Does anybody have any suggestions?

PS: I am not sure if this is a red herring, but I also am occasionally getting this message on the module admin page:

*Notice: Undefined index: step in views_bulk_operations_form_validate() (line 621 of /var/www/html/nidadev/sites/all/modules/contrib/views_bulk_operations/views_bulk_operations.module). Notice: Undefined index: step in views_bulk_operations_form_submit() (line 664 of /var/www/html/nidadev/sites/all/modules/contrib/views_bulk_operations/views_bulk_operations.module). Notice: Undefined index: select_all_pages in views_bulk_operations_form_submit() (line 711 of /var/www/html/nidadev/sites/all/modules/contrib/views_bulk_operations/views_bulk_operations.module). Notice: Undefined index: operation in views_bulk_operations_form_submit() (line 713 of /var/www/html/nidadev/sites/all/modules/contrib/views_bulk_operations/views_bulk_operations.module).*

  • That's in _views_bulk_operations_execute(): "if ($operation->aggregate()) {" You'll have to tell us what you're trying to do. (What action are you trying to take?). But I just tried to recreate this with latest VBO and commerce and had no trouble deleting products. Normally I'd say file an issue, but unless you can recreate it in a test environment (a simple Commerce Kickstart install) that won't do much good. Sounds like you have a bad VBO install. I'd rm -rf the current VBO and replace it with the latest and drush updatedb. If that didn't work, uninstall and reinstall. – rfay Dec 29 '11 at 12:50
  • Thanks Randy, I tried to do what you said, but it didn't seem to work. The interesting thing is that I have no problems on views that I have created after the update, I just have the problem on views created before the update – Stan Ascher Dec 29 '11 at 16:31
  • Look like I was mistaken ( I think) What I ended up doing after messing around with it for an hour was restoring the database from the night before. I had the a fresh version of VBO installed and now it works - (sort of) I do have to re-input the selected operations, but that is better than rebuilding all the views – Stan Ascher Dec 29 '11 at 17:54
  • There's an open VBO issue for this. Each person having the problem in the end had a misconfigured drupal install (a wrong cache in settings.php, etc). I've yet to find anyone with an actual bug (and I've looked at several actual installations with that problem). – Bojan Zivanovic Mar 29 '12 at 0:13
1

I flushed out the database, and started with a new fresh version of VBO.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.