3

When I click "Add content," I get the following message:

You have not created any content types yet. Go to the content type creation page to add a new content type.

However, under content types it lists all my content types (page, article, blog, etc). What could be causing this sort of miscommunication? The only change I made recently was moving the "Add content" link from one menu to another, but that shouldn't have affected the actual behaviour of node/add. (I did it using the admin interface as well; I didn't do any PHP editing of any sort.)

This is my recent log messages since the last content I added (edited out repeats and page not found errors):

cron    12/29/2011 - 13:02  Cron run completed. Anonymous (not verified)
php 12/29/2011 - 10:42  Notice: Undefined index: path in menu_edit_item...  admin
php 12/29/2011 - 10:42  Notice: Undefined index: path in menu_edit_item...  admin
user    12/29/2011 - 10:35  Session opened for admin.   admin
cron    12/29/2011 - 10:02  Cron run completed. Anonymous (not verified)
cron    12/29/2011 - 01:20  Cron run completed. Anonymous (not verified)
content 12/29/2011 - 00:37  page: updated Mentoring Program.    admin
content 12/29/2011 - 00:34  page: added Mentoring Program.  admin

Only change to any files was a small change to pages.tpl.php regarding rendering of page titles; and I haven't installed any modules since it last worked.

  • 1
    You're going to have to answer a few questions and do some debugging: 1. Was it showing content types before? 2. Have you installed any modules since this started happening? 3. Have you uploaded custom files or edited any files? – Mechaflash Dec 29 '11 at 18:49
  • I don't remember exactly when it started, but I don't think anything has changed, or any modules installed. Do you know if there's a simple way of seeing when the last time content was added was just so I can be sure? – Damon Dec 29 '11 at 20:12
  • 1
    www.mysite.com/?q=admin/reports/dblog That will give you the full log of any changes to your site. If I'm not mistaken, this should be enabled. – Mechaflash Dec 29 '11 at 20:41
  • good to know! I edited the q with some additional details abt updates and the log... – Damon Dec 30 '11 at 1:03
  • i found this drupal.org/node/997444 one of the dumbest bugs I've seen heh. Put things back and still not working.. – Damon Dec 30 '11 at 1:56
5

I found this :
http://drupal.org/node/997444
it seems like it's a very strange behaviour.

Basically I guess Drupal looks at that specific main menu to see what types of content can be created by users, so if even if you move all the options to a different menu none will be available.

I had to re-add the add-content link to the administration menu and re-check all the submenu items, then set it to display:none; and add the 'Add content' link to the user menu again.

1

Shot in the dark...permissions? I've hunted around for hours for a bug only to realise that I didn't actually have the permissions to perform the task in question.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.