0

I need to migrate a drupal site from one host to another. I didn't create the original. I tried using "Backup & Migrate", and I also tried to export the sql database in phpmyadmin from old site, import into new site, and move the file manually with ftp. My new host is GoDaddy. I can change that if GoDaddy causes issues!

Here is the problem, The theme used in the old site appears as an option, I can choose it, and the site works, but no content is there at all. All the modules show up in the new environment, still no content. I go to search for content, still no content. I can't find any pages anywhere!!!

Any help?

1
  • do you have phpMyAdmin or something to browse the database?
    – No Sssweat
    Jan 3 '16 at 7:59
2

So, the usual way to do this is like this.

  1. dump all caches and back up the database
  2. clean drupal install on your new server
  3. move the db to your new server
  4. configure proper db user on new server
  5. copy the sites folder to the new server
  6. make sure settings.php is correct for new server config
  7. run update.php

It's not clear from your description exactly what's happened, but I would try it again. From what you describe, it doesn't sound like you followed all the steps for a normal site migration, so you need to make sure all the stuff drupal needs is there. I've also had some issues with folder permissions when moving stuff to Godaddy, so you can look at that too.

1
  • Comments are not for extended discussion; this conversation has been moved to chat.
    – Clive
    Jan 3 '16 at 11:01
1

OK, I fixed it!!!! I'm really hoping this helps someone else at some point.

Detailed problem:

I was migrating a drupal site from a private host to GoDaddy subdomain host to test the files and sql db before going to live environment.

Drupal site migrated and everything looks right but no content is listed. No pages, no media, nothing. The proper theme was available as an option, but not selected.

in the settings.php file, the prefix that godaddy installed for me was "drup_", but my imported database tables didn't have "drup_" as a prefix.

Fix:

nizz0k was very helpful in pointing out that I need to run update.php. I had already tried that, but his comment about godaddy not allowing enough ram gave me the idea to increase the ammount of ram from godaddy. The error I was getting before increasing the ram, had to do with "not enough ram or exceeding available ram" something like that. As soon as i increased the resource level with godaddy, the update script worked.

So, to wrap it up, if you are hosting with godaddy, beware of the prefix.

  1. I had godaddy install the drupal app for me in the subdomain
  2. imported the sql db from my old host
  3. imported the files using ftp
  4. edited the settings.php file to get rid of the "drup_" prefix that godaddy had
  5. go to site.com/q=user to log into the site and have permissions
  6. go to site.com/update.php to update things

That's what worked for me. I'm really hoping this helps someone out. I was looking for something about this for more than 5 days before I posted the question.

Again, thank you so much for this website for hosting the forum, and most certainly thanks to nizz0k for the prompt response and excellent idea's!!

2
  • What threw everything off was that you used the GoDaddy installer rather than just transferring all of the Drupal files with ftp.
    – No Sssweat
    Jan 3 '16 at 10:26
  • 1
    IMO you should accept nizz0k's answer as what you wrote is pretty much #5 #6 #7 on his list.
    – No Sssweat
    Jan 3 '16 at 10:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.