0

I've installed Drupal 8 in a minimal installation; I've enabled CKeditor and created a text-format called "Full". I've also created a role named as "Administrator" and gave it all permissions available whatsoever; After that, I've attached my user "Admin" to that role "Administrator" and associated it with my newly created text-format ("Full"). I than decided I'm good to keep on:

After I did all of this I went to my content type and clicked to edit it's body field... When I went in to the edit screen I didn't see any place to attach the new text format I created to it, so where is the right place to set the field for other text-format rather than the default "plain text"?

enter image description here

1

You're already using it, default text-only shows up when there is no other choice.

If you add another format: ie: "test", now you will see in the drop down CKEditor and test.

Also, you probably did not select CKeditor as your text editor. Did you enable the CKeditor module?

enter image description here

I highly recommend not using minimal installation. I just tried it and a lot of the modules are disabled, just figuring this stuff out it's quite the headache.

Normal installation is the way to go IMO.

  • Indeed I've enabled both CKeditor module and Text editor modules... – JohnDoea Jan 7 '16 at 5:21
  • 1
    As you can see in my screenshot, not even my Admin role exists, which is quite puzzling. Perhaps I need to enable a module? ugh.. minimal installation makes me sick, lol. – No Sssweat Jan 7 '16 at 5:23
  • Indeed, I should have created the "Administrator" role from a scratch and install a Firefox "Check multiple boxes" add-on to check all the permission boxes for it lol... – JohnDoea Jan 7 '16 at 5:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.