2

I've configured a rule to send an email after a commerce order is placed containing products of a particular type. That works fine. The body though is a view token ([views:embed:golf_registration_information:default]) pulling in specific order info (couldn't do this through the rule with the info I wanted to include). However in the email, I'm getting "edit view" links in a few places, which obviously I don't want.

Here's what the link looks like: http://website.com/admin/structure/views/view/golf_registration_information/edit/default?destination=checkout/451/paypal_ec

I can't figure out how they are getting in there. Is there a setting I'm missing in Views? It appears as the first thing in the body, and then within the body above the line items table. Obviously I didn't add anything within the Global Custom Text field that's outputting the fields.

Modules I'm using: D7, Commerce, Commerce Rules Extra, Rules, Mimemail, Views, Token Embed Views

  • Can you show the email, too? – nvahalik Jan 8 '16 at 18:57
3

Sounds like you need to disable contextual links:

enter image description here

| improve this answer | |
  • Well that got rid of the top link. The one in the body still exists. Going to investigate further... Thanks! – cfox Jan 8 '16 at 18:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.