0

I'm trying to update my colorbox module and I keep getting the error:

Update failed! See the log below for more information. Your site is still in maintenance mode.

and below it says:

colorbox

Error installing / updating File Transfer failed, reason: Cannot remove directory /home/content/02/12910502/html/sites/all/modules/colorbox/..

Next steps Your modules have been downloaded and updated. Run database updates

why do I get this error and how can I get this fixed?

EDIT1
I'm using GoDaddy shared hosting. All permissions for files & directories in ftp are set to 755 (owner 12910502) within colorbox/ but I still get this error... - I've never had a problem on other sites I'm working with, weird.
This is drupal core 7.15 - may that be the reason?

EDIT2
How abut if I just replace the directory onthe ftp with the latest version and then run update.php, should this work too?

  • 1
    WOW why on earth are you using 7.15 core? You need to update ASAP as there have been many security fixes. EDIT2 sounds like a great idea. – No Sssweat Jan 9 '16 at 19:41
  • EDIT2 is what I ended up doing. As for why I'm with 7.15 - just because that was the latest when I built the site and I haven't touched it since unil now... – cerr Jan 9 '16 at 19:59
2

Sounds like a permission issue.

If you're using ubuntu, make sure the user owner for your modules folder is www-data and 755 permission.

Also, don't forget to run update.php by going to www.yourwebsite.com/update.php after you update drupal core OR any module.

  • I changed my owner to the user-name (benwork) and the group name to www-data ... the permissions of www are (recursively) 755... I had no problems with this arrangement... In contrast to others (long story) :) – JohnDoea Jan 9 '16 at 6:14
  • @benos oops my meant to say 755, thx. – No Sssweat Jan 9 '16 at 6:19
  • please see EDIT1 above – cerr Jan 9 '16 at 17:13
0

I ended up upgrading the modules as I suggested in EDIT2 above. Worked fine except ctools, that module is still pending...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.