1

I have a field collection displayed in a view. Currently, it renders it this way: image

I'd like to render all items in one green box though, not all items in a box seperately. I thought I would be able to do this using "style settings" in the view settings.

However, this doesn't seem to work. I've tried all different options, but the class I provide is NOT added in the elements and so the display doesn't change.

Why doesn't that work? Am I wrong by using style settings to achieve this?

3 Answers 3

1

Add a class to your view by doing this:

enter image description here

8
  • This seems to be adding the class to the individual items...
    – Bv202
    Commented Jan 11, 2016 at 12:14
  • @Bv202 did you flush the cache?
    – No Sssweat
    Commented Jan 11, 2016 at 12:19
  • yup, I did several times (same with my browser cache)
    – Bv202
    Commented Jan 11, 2016 at 12:35
  • @Bv202 not with your browser, in drupal
    – No Sssweat
    Commented Jan 11, 2016 at 12:36
  • Yes, I know what you meant :) it appears I was wrong: the class simply doesn't seem to get added...
    – Bv202
    Commented Jan 11, 2016 at 12:37
0

In your View

Click on your Field Collection Field and scroll down to the setting "Multiple Field Settings".

Select "Display all values in the same row". That should do the trick.

enter image description here

6
  • Hmm, I've never seen that option. Could you tell me where exactly I can find it?
    – Bv202
    Commented Jan 11, 2016 at 12:40
  • @Bv202 read the bold part, it says there =)
    – No Sssweat
    Commented Jan 11, 2016 at 12:41
  • Yes, but there is no "Multiple Field Settings"..
    – Bv202
    Commented Jan 11, 2016 at 12:42
  • @Bv202 I found this Missing Multiple Field Settings
    – No Sssweat
    Commented Jan 11, 2016 at 12:45
  • It's set on "Unlimited" :s
    – Bv202
    Commented Jan 11, 2016 at 12:47
0

Could you share a screenshot of your settings? However, in the Format section i would go to settings and group my fields. Then add a class for each row, right after Grouping setting

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.